会员登录

自动登录   |    忘记密码 新会员注册

指南-如何回滚天际-新的Steam更新修复

作者:Sthaagg Memnochs
发布:LUOHUISHU98
发布日期:2020-02-16 23:18:08
更新时间:2020-02-16 23:18:08
头像
655
260 人收藏
1445 次下载
5723 次浏览
1.5.80
上古卷轴5:重置版
本地下载 高速下载 需要优先下载下载器,50%提速

更新后如何修复天际

未加密您喜欢的skse mod



用途:

每次Bethesda更新我们喜欢的游戏时,它们都会破坏与SKSE及其许多插件的兼容性。避免这种情况的最好方法是阻止Steam的自动更新(如下所述)。问题,如果游戏已经更新,那么您就搞砸了。


大多数更新仅包含用于改进Creation Club的修复程序或功能。

所以我们大多数人都不在乎它们,因为大多数错误修复已包含在mods中,可以在此处找到。

如果您是CC用户,并且从此处使用mod,则可以尝试此方法,撤消很容易,如果遇到问题,您只需要重新运行更新即可。


怎么样?

我们将需要直接从Steam服务器还原旧版Skyrim。为此,我们将使用SteamDB获取Skyrim的AppID和DepotID,然后使用Depot Downloader命令下载所需的版本。

我将在下面说明每个步骤,您可以直接从下载部分下载每个天际版本的PDF,其中包含所需的命令行。


遵循本指南并避免重做所有步骤后,如果可以,请备份整个Skyrim SSE文件夹;)


重要的提示:

不要使用屏幕截图中的数字,它是针对Skyrim 1.5.39的。

下载部分的主文件包含命令以回滚到实际版本n -1(当前版本为1.5.97 / Skse 2.0.17,因此预制文件适用于1.5.80 / SKSE 2.0.16)

旧文件为先前版本(请检查skse版本以选择所需的文件)


⚠警告:某些更新会更改基本游戏文件(大多数情况下为update.esm),仅将exe文件降级是不够的。因此,请检查蒸汽变更日志或执行额外的步骤)



第一步:如何阻止更新


进入您的Steam“图书馆”

打开“上古卷轴V:天际特别版”属性(右键单击游戏条目)

转到更新选项卡,并将其设置如下:


使用SKSE快捷方式启动游戏(或从您的Mods Manager指向skse的游戏)

</ s> </ s> </ s>


第二步:安装软件仓库下载器


转到.NET Core Runtime下载页面

单击下载.Net Core Runtime链接(运行应用程序)

下载最新的DepotDownloader版本

在您需要的地方解压缩它,在本指南中,我们将在C:\ DepotDownloader中解压缩它


第三步:获取所需信息


转到SteamDB,然后在搜索字段中键入“ Skyrim”。

</ s> </ s> </ s>

请注意应用程序ID(由橙色矩形圈出),然后单击它。

</ s> </ s> </ s>

单击左侧的软件仓库选项卡(橙色圆圈),然后注意包含“ Skyrim Special Edition exe”文件的软件仓库ID(橙色圆圈),然后单击它。

</ s> </ s> </ s>

单击“清单”选项卡(橙色圆圈)。在列表中选择要下载的版本,在本示例中,我圈出了2018年4月3日之后的版本,因为该版本是最后一个“经过验证的版本”。注意它的清单ID。

</ s> </ s> </ s>



第四步:下载所需文件


打开Windows命令行窗口(按Ctrl + R,然后键入CMD)

转到解压缩Depot Downloader的文件夹:

输入c:然后按Enter

键入cd DepotDownloader,然后按Enter

使用软件仓库下载器下载所需的文件*:

键入(不带<>)depotdownloader.bat -app <ID> -depot <ID>-清单<ID>-用户名<YOURSTEAMACCOUNT> -dir c:\ download

在询问时输入密码,然后输入您的Steam Guard代码

将下载的文件复制/粘贴到您的SSE文件夹中

和瞧!


*您可以根据需要替换c:\ download。


常问问题:


问:如果需要,可以安装更新吗?

答:是的,这就是我们阻止更新的原因,您可以通过直接从Steam启动游戏或检查游戏文件的完整性来运行更新。


问:现在,我的天际不再使用我的语言,该怎么办!?

答:您需要使用相同的方法下载语言包。


问:我可以开始一个新游戏,但我的屏幕无限加载,或者屏幕保持黑屏?

答:使用BethINI重建您的INI


问:我收到消息Depot Download Complete,但是仍然弹出SKSE错误?

答:遵循第一步:在尝试安装旧版本之前,如何阻止更新。

要么

答:从steamapps \ content \ app_489830 \ depot_489833文件夹复制/粘贴“ SkyrimSE.exe”到Skyrim SSE文件夹。


问:不需要它/无用,您只需要还原备份/使用Windows还原或任何已知的解决方案...

答:是的...如果您有备份/使用Windows恢复或任何已知的解决方案,则此指南适用于面临问题的人员。


问:这个mod没用,因为我自己可以做!

答:我这样做是为了方便用户,如果您知道该怎么做,为什么不先发布它呢?自私的愤怒巨魔!


问:我不喜欢你!

答:这就是生活:p


问:此常见问题解答无用!

答:是的!


问:为什么要这么做?

答:因为我喜欢,所以我可以

————————————————————————————————

How to repair your skyrim after update
Unbreak your preferred skse mods



Purposes:
Each times Bethesda update our favorites games, they break compatibility with SKSE and a lot of its plugins. The best way to avoid that is to block automatic update from Steam (as explained below). Problem, if the game is already updated, you are screwed.

Most of the update contains only fixes or features to improve the Creation Club...
So most of us doesn't care about them as most of the bug fixes are already covered by the mods which can be found here.
If you are a CC users and you use mod from here, you can try this method, it is easy to undo, if you face problem you simply need to rerun the update.

How?
We will need to restore an older Skyrim version directly from Steam server. For that we will use SteamDB to get Skyrim's  AppID and DepotID then use Depot Downloader command to download the needed version.
I will explain every steps below, you can download a PDF which contains the needed command line directly from the download section for each skyrim version.


After following this guide and to avoid to redo all the steps, if you can, do a backup of your entire Skyrim SSE Folder ;)

Important Note:
Don't use the numbers from the screenshot, it was for Skyrim 1.5.39.
Main files from download section contain command to rollback to actual version n -1 (Current version is 1.5.97 / Skse 2.0.17 so pre-made files are for 1.5.80 / SKSE 2.0.16)
Old files are for previous version (check skse version to choose which one you need)

⚠ Warning: Some updates alter base game files (most of the time update.esm), downgrading only the exe file could not be enough. So check steam changelog or go through the extra step)



First Step: How to block update

Go in your Steam "Library"

Open "The Elder Scrolls V: Skyrim Special Edition" properties (right click on game entry)

Go to Update tab and set it as follow :

Use SKSE shortcut to launch your game (or the one which point to skse from your mods manager)




Second Step: Install Depot Downloader

Go to  .NET Core Runtime download page

Click on Download .Net Core Runtime link (Run apps)

Download last DepotDownloader Release

Unpack it where you want, in this guide, we will unpack it in C:\DepotDownloader


Third Step: Get needed information

Go to SteamDB, and type "Skyrim" in the search field.


note the app ID (circled by an orange rectangle) and click on it.


Click on the depots tab on the left (circled in orange), then note the depot ID (circled in orange) which contains the 'Skyrim Special Edition exe" file then click on it.


Click on the Manifests tab (circled in orange). Choose in the list the version that you want to download, for this example I circled the one from April 3, 2018 as this version is the last "validated one". Note its manifest ID.





Fourth Step : Download needed files

Open windows command line windows (Press ctrl + R, then type CMD)

Go to the folder where Depot Downloader is unpacked :

Type c: then hit enter

Type cd DepotDownloader then hit enter

Use Depot downloader to download the needed files *:

Type (without the <>) 

depotdownloader.bat -app <ID> -depot <ID> -manifest <ID> -username <YOURSTEAMACCOUNT> -dir c:\download

Type your password when asked, then your Steam Guard Code

Copy / paste downloaded file to your SSE folder

And Voila !


* You can replace c:\download by what you want.

FAQ:

Q: Could I install the update if i want / need ?
A: Yes, this is why we block update, you can run the update by launching the game directly from steam or by checking game files integrity.

Q: Now, my Skyrim is not in my language anymore, What can I do !?
A: You need to download your language package by using same method.

Q: I can start a new game but I suffer of infinite loading screen / my screen stay black ?
A: Rebuild your INI with BethINI

Q: I obtain message Depot Download Complete but SKSE error still pops up ?
A: Follow First Step: How to block update before trying to install older version.
or
A: copy / paste "SkyrimSE.exe" from the steamapps\content\app_489830\depot_489833 folder to your Skyrim SSE folder.

Q: No needs of it / Useless, you only need to restore your backup / use windows restoration or any solutions you know...
A: You're right... If you have a backup / use windows restoration or any solutions you know... This guide is for people which face the problem.

Q: This mod is useless because I can do it myself !
A: I did it for user convenience, if you know how to do it why you don't release it before ? Selfish angry troll !

Q: I don't like you !
A: It's life :p

Q: This FAQ is useless !
A: Yes !

Q: Why you did it ?!
A: Because I like it and I can !


原贴地址
1.版本号: 1.5.80   更新时间: 2020-02-16 23:23:19

选择快速回复类型:
  • 感谢
  • 支持
  • 疑问
  • 卖萌
  • 关心
  • 傲娇
评论


    作者精品
    logo

    指南-如何回滚天际-新的Steam更新修复


    Mod大小:10.82KB
    上传时间:2020-02-16 23:18:08

    Mod简介:

    暂无更多介绍


    选择快速回复类型:
    • 感谢
    • 支持
    • 疑问
    • 卖萌
    • 关心
    • 傲娇
    回复

    closeAD